So today I faced again the problem of unsatisfied dependencies. When I tried to update my client, I got the following error message:

error: failed to prepare transaction (could not satisfy dependencies):: ffmpeg2.80: ...

This problem could easily be solved by uninstalling ffmpeg, update your system and reinstall it again.
This problem occurs due to the issue, that ffmpeg v2.80 was removed from the repositories.

Further reading: https://bbs.archlinux.org/viewtopic.php?id=235203